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Submenus Width 
Change all submenus default width 
 
 
 

Online Support 
 
http://www.selteco.com/support/smmk.htm 
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Menu ID 
Define unique menu id string, if you use more than one menu on a page set  unique 
ids for each menu.  
 
Custom Arrow 
If you don’t want use standard wingding arrows not visible under some browsers 
use transparent gif images and enter absolute urls to your arrow images. 
 
Top Menu Menu 
 
Style 
Switch between horizontal and vertical styles 
 
Background Color, Border, Separator/Arrow Color 
Change background colors and top bar appearance 
 
Padding 
Distance between top cell border and top menu text 
 
Top Menu Width 
Total width of the top bar 
 
Top Item Height 
Total height of the top item including borders and padding 
 
Select Font, Font Color, Font Highlight 
Change top menu text appearance 
 
 
Sub Menus Menu 
 
Custom Colors 
If checked submenus have different color settings than top menu 
 
Background Color, Border Color, Space Color, item Highlight 
Change colors of the submenu 
 
Padding 
Distance between subitem cell border and subitem text 
 
Custom Font 
If checked submenus have different font settings than top menu 
 
Select Font, Font Color, Font Highlight 
Change submenu menu text appearance 
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Thank you for using Selteco Menu Maker. Menu Maker enables you to design 
DHTML dropdown menus for your web pages. Your menu as a simple JavaScript 
file can be easily included in any web page. The menu made with Menu Maker is 
safe for any browser version. Menus are compatible with the following browsers:  
Internet Explorer 4.x  
Internet Explorer 5.x  
Netscape Navigator 4.x  
Netscape Navigator 6.x  
Opera 6.x 
Mozilla 1.6 or above  
FireFox 1.5 
Apple Safari 
 
When you start Menu Maker it will create a new document. The window contains 
two panes. The left pane with the menu tree, the right pane with browser preview, 
updated live whenever the menu content changes.  
Choosing the menu mode 
Menu Maker provides 3 ways to create your web menu – "standard", "relative" and 
"fixed" mode 
 
“Standard” menu allows 1 submenu level. Web page integration is easy with a 
single SCRIPT tag,  the menu will appear where the tag is placed, for example in a 
table cell. Standard menu has fixed submenu width. 
 
"Relative" menu is the easiest to design and to integrate with your web page. It 
appears on the page according to current html flow, wherever included with the 
"script" tag. It doesn't need exact positioning, width or height of the menu. Submenu 
width is automatic. 
 
"Fixed" menu provides additional submenu level. It is independent of the html flow, 
you have to specify x and y position, menu width and height. Unlike the "relative" 
menu, "fixed" menu is compatible with browsers other than Internet Explorer. To 
position the fixed menu on the screen choose "Fixed Menu Properties" command 
under "Menu" menu.  
 
To switch between "fixed", "standard" and "relative" mode use commands located 
under "Menu" menu. 
 
Because fixed menu needs fixed x and y position, you can use it with left aligned 
web page only. If your page is centered you will not be able to position the menu in 
the right place.  
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Set image icon, you should use online available images like 
http://www.mywebsite.com/image.gif 
 
Item Icon 
Selects wingdings or webdings symbol to display on the lef t of the item 
 
Item Color 
Selects individual item color 
 
Submenu Position 
Change default submenu position, use positive values to shift the menu right and 
negative to shift the menu left. 
 
JavaScript OnClick 
Define customized action for onclikc event, you have to use javascript commands 
 
Menu Menu 
 
View HTML code 
Displays HTML tags necessary to include the menu in the web page 
 
Select base URL 
Change base URL, all URLs and image paths will be prefixed with the base 
 
Add extra HTML 
Enter custom HTML code added after the menu code in the JS file 
 
Menu Colors 
Edit menu appearance 
 
Relative, Standard, Fixed 
see “Choosing right menu mode” 
 
Menu Options 
Change menu dimensions 
 
Image Decoration 
See “Image Decoration” 
 
Language 
Change preview page charset 
 
Prefixes 
See “Custom path to images folder” 
 
Icons 
Change icon appearance, color, width 
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File Menu 
 
New 
Creates new menu project 
 
Open 
Opens existing menu (smmp file) 
 
Save Project, Save As 
Saves current file and allows to edit it later 
 
Export JavaScript file 
Generates the menu in JS format. Copy the file to your web site to use the menu 
 
Export Menu 
Exports all files necessary to view th menu, JS file, GIF images and a sample HTML 
page 
 
Edit Menu 
 
Undo 
Undoes last action 
 
Add item 
Adds new menu item below item selected in the left pane 
 
Create submenu 
Adds a submenu under selected item. Menus can have 2 or free levels, see 
“Choosing right menu mode” 
 
Delete Item 
Removes selected item (and sumbenu if exists) 
 
Find&Replace 
Finds and replaces text strings (labels, prompts, urls) in your menu project 
 
Top Item Width 
Set custom top item width, 0 means the width is set globally 
 
Items Properties 
Edits item URL, prompt, target 
 
Symbol Icon 
Set Wingding icon, the icon may not be visible under browsers other than IE 
 
Image Icon 
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Adding menu items 
 
 
To add a new menu item use "Add Item" command located in "Edit" menu. Specify 
menu name in the dialog and the URL. New item is added after currently selected 
item.  
 

 
 
Menu Name 
Item name displayed in the menu. 
 
URL 
You can specify any valid URL. It is better to provide absolute URLs, not relative. If 
you want to use relative paths you may encounter some problems described later in 
this manual (see the topic Setting URLs.) Absolute URLs begin with 
http://www.yourwebsite.com/... 
 
If you don’t want the item to be linked check “Free HTML” option and enter item 
name in the free html field. 
 
Target 
The following target names are reserved and have special meanings. 
"_blank" The user agent should load the designated document in a new, unnamed 
window.  
"_self" The browser should load the document in the same frame as the element 
that refers to this target.  
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"_parent" The browser should load the document into the immediate FRAMESET 
parent of the current frame. This value is equivalent to _self if the current frame has 
no parent.  
"_top" The browser should load the document into the full, original window (thus 
canceling all other frames). This value is equivalent to _self if the current frame has 
no parent.  
 
Prompt 
This value defines popup text displayed by the browser when the user moves the 
mouse cursor over the menu item. 
Adding submenus 
In relative and standard mode you can have menu 2 levels (top menu and 1 
submenu). In fixed mode you can use 3 levels (top menu and 2 submenu levels) 
 
To add a submenu choose “Edit” > “Create Submenu...” command. You have to 
select top menu item first to enable this command, or select 1st level submenu item 
if you are in fixed mode. 
 
After you choose this command you will have to enter menu name and menu URL 
the same way as for adding an item. 
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Image Decoration (Menu Styles) 
 
Fixed and Standard menus can have custom image background called "image 
decoration". 
 
To decorate the menu choose "Menu" > "Image decoration" command. Choose one 
of the styles and click OK.  
 
After you choose image style you can set menu background color. Choose "Menu" 
> "Background color..." command. Avoid pure colors like pure red or blue color, or 
the texture will not be visible. If you don't see image structure choose neutral color 
like gray ( RGB 128 128 128). 
 
With "Menu" > "Image decoration" command you can also choose arrow style. 
Menu Maker can display arrows to indicate 2nd level submenus only, or to indicate 
all submenus.  
 
To change the arrow color set the separator color in the "Menu Properties" toolbar. 
 
Menu Maker is using 4 images for the top menu bar: left edge, background, right 
edge and separator image. These images must be exported with .js file. 
 
To export all necessary files choose "File" > "Export HTML page" command. Select 
file name and click OK. Menu Maker will export necessary files and display file list. 
You have to copy the images with .js file to your web folder. 
 
Custom path to images folder 
 
By default images have no path. If you use multi-folder structure you have to put 
images in the root or any other specified folder and adjust the path to the images. 
 
Choose "Menu" > "Prefixes" command and enter the target path to decoration 
images (lx..gif, rx.gif, bx.gif, sx.gif) after you copy the files to your web folder. For 
example if the decoration image will available at 
http://www.mywebsite.com/images/s1.gif use the prefix 
http://www.mywebsite.com/images/ 
 
 
Adjusting p adding with image decoration 
 
Some background images look better at certain font size and padding. Adjust the 
padding to increase or decrease space between menu items, or adjust the font size. 
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Sett ing up frame target for each menu item. 
To define the target for a menu item, double click it in the left pane in Menu Maker.  
"Home" item must target entire browser window, so its target is set to "_TOP":  
 

  
 
Item 1 and its Subitem 1 target the "RIGHT" frame:  

 
 
 

Selteco Menu Maker 4 

7 

Menu properties 
You can control the appearance of the following menu elements: 
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Fixed Menu properties 
Fixed menu needs additional options like x and y position or top bar with. Choose 
“Menu” > “Menu Options...” to set fixed menu properties: 
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The menu is loaded in the left frame as illustrated below:   
 

 
Menu items will target the "right" frame, so when a user clicks a menu item, the link 
will open in the right frame. 
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Observe that URLs will point to the right place after you specify correct base URL: 
 

 

Targeting Frames with Menu Maker 
In the following multi-frame scenario the menu items will target different frames 
specified by the user. Menu is placed in the left frame. 

  
 
The following code defines the frameset (file main.htm):  
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Exporting Menu 
To export the menu choose “File” > “Export JavaScript file...” command. After the 
file is saved you will have to copy HTML code, necessary to include your menu to 
your web page. Click “Copy” to copy the text to the clipboard.  
 

 
 
Use absolute path to .JS file. 
If you check this option Menu Maker will use the full path to your menu file, for 
example “C:\yourfolder\yourmenu.js”. This option should be used for testing 
purposes only. Full path will work if you view your web page locally on your 
computer. Once you upload your web page the menu will not be visible. 
 
Browser safe 
If you check this option Menu Maker will add <NOSCRIPT> commands for older 
browsers that do not support javascript or have security options set to disable 
javascript. 
Also search engines will be able to index your web pages linked by the menu. 
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Using Menu with HTML editors 
Once you export the JS file and copy the HTML code to your clipboard you can 
switch to your HTML editor and use the SCRIPT tag to display the menu. 
 
Placing relative menu 
Relative menu will appear wherever included so you can use a table to position the 
menu. Sample HTML code may look like: 
 
<HTML> 
<HEAD> 
<TITLE>Your web site title</TITLE> 
<META NAME="DESCRIPTION" CONTENT="My excellent web site"> 
</HEAD> 
<BODY BGCOLOR=#FFFFFF> 
 
<CENTER> 
This is my web site.  <P> 
 
<TABLE WIDTH=750 CELLSPACING=0 CELLPADDING=0 BORDER=0> 
<TR VALIGN=MIDDLE> 
<TD BGCOLOR=#F060C0 NOWRAP> 
 
<SCRIPT SRC="mymenu.js"></SCRIPT> 
 
</TD> 
<TD ALIGN=RIGHT NOWRAP BGCOLOR=#6080C0 >Other cell</TD> 
</TR> 
</TABLE> 
 
</CENTER> 
</BODY> 
</HTML> 
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Test version 
To make the links work in your design environment you have to use relative paths 
(add the location to your HTML files): 

 
Set relative paths in item URL: 
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 Observe full URL combined of base URL and item URL: 
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Placing fixed menu 
 
To achieve the best compatibility you should place the SCRIPT tag right after the 
BODY tag. Because the menu is already positioned in Menu Maker, it doesn’t 
matter where you place the SCRIPT tag in the HTML flow. 
 
You should make room for the menu using a blank paragraph or blank table cell. 
 
Your web page should be left aligned, otherwise the menu will be in the wrong 
position when you resize the browser window. 
 
<HTML> 
<HEAD> 
<TITLE>Your web site title</TITLE> 
<META NAME="DESCRIPTION" CONTENT="My excellent web site"> 
</HEAD> 
<BODY BGCOLOR=#FFFFFF> 
 
<SCRIPT SRC="mymenu.js"></SCRIPT> 
 
This is my web site. 
<P> 
 
<TABLE WIDTH=750 CELLSPACING=0 CELLPADDING=0 BORDER=0> 
<TR VALIGN=MIDDLE> 
<TD BGCOLOR=#F060C0 NOWRAP> 
 
&nbsp; 
<!-- BLANK TABLE CELL FOR THE MENU --> 
 
</TD> 
<TD ALIGN=RIGHT NOWRAP BGCOLOR=#6080C0 > 
Other table cell 
</TD> 
 
</TR> 
</TABLE> 
 
</CENTER> 
</BODY> 
</HTML> 
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Positioning fixed mode menus 
 
Positioning the menu in fixed mode is a bit tricky. To integrate the menu with your 
page follow the steps:  
 
Export the menu to .js file. To do so choose "Export JavaScript" file from the "File" 
menu. Save the file to the same folder where your html page is.  
"HTML Include Code" dialog will popup. Click "Copy" button to copy the code to 
clipboard. The code is the same every time you export the .js file so you have to 
copy it only once. The code usually looks like below:   
<SCRIPT SRC="mymenu.js"></SCRIPT>  
Switch back to your HTML editor, then copy the code right after the BODY tag. The 
code can not be placed within any TABLE tags  
Refresh your HTML page to see if the menu appears. The menu will be probably in 
wrong position.  
If necessary you have to make dummy table cell in your HTML code, so the menu 
doesn't overlap page contents.  
Switch back to Menu Maker to position your menu precisely. Choose "Fixed Menu 
Options" from "Menu" menu. Set X and Y coordinates and click OK.  
Export your menu to .js file like in step 1. You don't have to copy and paste the 
code again.  
Switch back to your HTML editor and refresh your page. See if the menu is in right 
position. If necessary repeat steps 6 to 8. 
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Setting URLs for sample web site 
Sample web site consists of the following files: 
index.htm 
products/index.htm 
products/prod1.htm 
products/prod2.htm 
contact/index.htm 
 
Online version  
Resides under www.website.com. You have to publish html files online to make the 
links work. 
To set base URL, choose “Menu” > “Select Base URL...”, make sure you add 
trailing slash: 

 
 
 
Setting item URL for “Product 1”, make sure you add leading slash. 
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Where "myimage.gif is the name of your image file. Make sure WIDTH and HEIGHT 
match your image dimensions. The image may not be visible in preview mode. You 
will see the image in the menu after you export the .js file and copy your image files 
to the same folder, together with your .js file.  
Setting URLs 
Absolute URLs 
Absolute URL looks usually like “http://www.website.com/folder/subfolder/file.htm” 
you may also omit leading web site name and use “/folder/subfolder/file.htm” only, 
the leading slash makes the URL absolute. 
 
Relative URLs 
Relative URL is usually a file name, or a folder with a file name. The URL is relative 
to the current location. Relative URL examples: “file.htm” or 
“folder/subfolder/file.htm” (without leading slash). 
 
To make sure that your links will work you should use absolute URLs. You can use 
relative URLs only if your web site is small and it has one level of depth (all files are 
in single folder) 
 
Relative URLs don’t work in preview mode. 
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Using Menu Maker with Microsoft FrontPage. 
Follow the steps below to import Menu Maker file to FrontPage editor.  
 
While using FrontPage find out the root of your local web in "Folder List" window. In 
this case the root folder is "C:\My Webs\myweb". If the folder list is not visible 
choose "Folder List" command located under "View" menu.  
  

 
Export JavaScript file from Menu Maker to the above root folder. To do so switch to 
Menu Maker and choose "Export JavaScript File..." from "File" menu. Navigate to 
the root folder, name .js file and click "Save" button  
In "HTML Include Code" popup click "Copy" button to copy the code to clipboard.  
Switch back to FrontPage editor. Hit F5 key to refresh "Folder List" window. You 
should see your .js file in the list.  
Position the cursor where the menu should appear. Make sure you are in "Normal" 
view mode.  
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Choose "Insert" > "Advanced" > "HTML" command  
Paste the code in the "HTML Markup" dialog:  
  

 
Save the page using "Save" command located under "File" menu. The page must 
be saved in the same folder as the .js file is. Otherwise you have to adjust the path 
to .js file in the SCRIPT tag.  
Switch to "Preview" mode to enjoy the menu 

  
 
If you're familiar with HTML code you can paste the code directly in HTML view. 
Switch from "Normal" to "HTML View", position the cursor between your html body 
tags and paste the Menu Maker code:  
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The menu is compatible with Apple Safari. 
To ensure Mac Internet Explorer compatibility follow the suggestions below. 
 
Fixed menu tag should be placed immediately before closing BODY tag.  
 
Wrong: 
 
<TABLE CELLSPACING=0 CELLPADDING=0 BORDER=0><TR><TD> 
<SCRIPT SRC=mymenu.js></SCRIPT> 
</TD></TR></TABLE> 
 
Suggested solution: 
 
<TABLE CELLSPACING=0 CELLPADDING=0 BORDER=0><TR><TD> 
...all page goes here 
</TD></TR></TABLE> 
<SCRIPT SRC=mymenu.js></SCRIPT> 
</BODY> 
</HTML> 
 

Free HTML 
 
FreeHTML option gives you virtually unlimited access to menu cell contents. You 
can use any HTML tags available for HTML body, such as <B>, <FONT> or 
<TABLE>. Menu Maker does not verify your HTML code so you are responsible for 
checking your syntax and closing HTML tags. You can not use line breaks in the 
code. 
 
You can also use HTML code directly in the “Menu Name” field. 
 
To use images as menu items use double click your item in the left pane to open its 
properties and put the following code in the dialog: 
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Netscape 4.x compatibility 
 
If you want to keep Netscape 4.x compatibility follow the suggestions below. 
 
Fixed menu tag should be placed immediately after the BODY tag. Placing the tag 
inside a table may cause the menu unavailable under Netscape 4.x. It is not 
necessary to place the tag inside a table, because fixed menu is positioned using 
absolute x and y coordinates. 
Wrong: 
 
<TABLE CELLSPACING=0 CELLPADDING=0 BORDER=0><TR><TD> 
<SCRIPT SRC=mymenu.js></SCRIPT> 
</TD></TR></TABLE> 
 
Suggested solution: 
 
<BODY> 
<SCRIPT SRC=mymenu.js></SCRIPT> 
<TABLE CELLSPACING=0 CELLPADDING=0 BORDER=0><TR><TD> 
... 
</TD></TR></TABLE> 
 
 
 
Using "Free HTML" 
If the item is created using "Free HTML" code and the item has a submenu, the 
submenu will not drop-down under Netscape 4.x.  
 
Naming .JS file 
If you name your .JS file with spaces, for example "My Menu.js" the menu will not 
be loaded by Netscape 4.x browser. Don't use spaces in the name of .JS file. In 
above example "MyMenu.js" name should be used. You can also use "%20" sign to 
replace spaces, in this example you can use the name "My%20Menu.js":  
Wrong: 
 
<SCRIPT SRC="My Menu.js"></SCRIPT> 
 
Suggested solution: 
 
<SCRIPT SRC="MyMenu.js"></SCRIPT> 
 
Or: 
 
<SCRIPT SRC="My%20Menu.js"></SCRIPT> 
 
Mac OS compatibility 
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<SCRIPT SRC="mymenu.js"></SCRIPT>  
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Using Menu Maker with Macromedia Dreamweaver. 
 
Find ou t what is the Local Root Folder of your web site: 
 
Launch or switch to Macromedia Dreamweaver  
Choose "Define Sites" from "Site" menu  
Select your site and click "Edit"  
Note down Local Root Folder of your site  
  

 
Export .JS file from Selteco Menu Maker: 
 
 
Launch and open your menu or switch to Selteco Menu Maker  
Choose "Export JavaScript File" from "File" menu  
Navigate to Local Root Folder and save your .js file  
Switch back to Macromedia Dreamweaver and make sure the file is visible in "Site" 
view  
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Include .JS file: 
 
 
Switch back to Selteco Menu Maker  
Choose "View HTML Code" from "Menu" menu and copy the code  
Switch back to Macromedia Dreamweaver and paste the code  
Press F12 key to enjoy your page in the browser 
 
 

 


